const regex = /(\[bold\]?)(.*?)(\[\/bold\]?)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[bold\\]?)(.*?)(\\[\\\/bold\\]?)', 'gi')
const str = `Hallo [bold]ik[/bold] ben een zin [bold]met bold[/bold]`;
const subst = `<CharacterStyleRange FillColor=""> <Properties> <AppliedFont type="string">$2</AppliedFont> </Properties> <Content>Hallo</Content> </CharacterStyleRange>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);