$re = '/(\[bold\]?)(.*?)(\[\/bold\]?)/i';
$str = 'Hallo [bold]ik[/bold] ben een zin [bold]met bold[/bold]';
$subst = "<CharacterStyleRange FillColor=\"\"> <Properties> <AppliedFont type=\"string\">$2</AppliedFont> </Properties> <Content>Hallo</Content> </CharacterStyleRange>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;