const regex = /Sent/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Sent', 'gi')
const str = `Sent`;
const subst = `&BB4EQgQ,BEAEMAQyBDsENQQ9BD0ESwQ1-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);