import re
regex = re.compile(r"Sent", flags=re.IGNORECASE)
test_str = "Sent"
subst = "&BB4EQgQ,BEAEMAQyBDsENQQ9BD0ESwQ1-"
result = regex.sub(subst, test_str)
if result:
print(result)