import Foundation
let pattern = #"Sent"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"Sent"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"&BB4EQgQ,BEAEMAQyBDsENQQ9BD0ESwQ1-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)