using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)hreflang\s*=\s*['""]?de-de[^>]+href\s*=\s*['""]?([^'""]*)['""]?|href\s*=\s*['""]?([^""']*)['""]?[^>]+hreflang\s*=\s*['""]?de-de['""]?";
string input = @"<link rel=""alternate"" hreflang=""de-de"" href=""https://zrce.eu/"" />
<link rel=""alternate"" hreflang=""en-us"" href=""https://zrce.eu/en/"" />
<link rel=""alternate"" hreflang=""it-it"" href=""https://zrce.eu/it/"" />
<link hreflang=""de-de"" rel=""alternate"" href=""https://zrce.eu/"" />
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}