use strict;
my $str = '<link rel="alternate" hreflang="de-de" href="https://zrce.eu/" />
<link rel="alternate" hreflang="en-us" href="https://zrce.eu/en/" />
<link rel="alternate" hreflang="it-it" href="https://zrce.eu/it/" />
<link hreflang="de-de" rel="alternate" href="https://zrce.eu/" />
';
my $regex = qr/(?i)hreflang\s*=\s*['"]?de-de[^>]+href\s*=\s*['"]?([^'"]*)['"]?|href\s*=\s*['"]?([^"']*)['"]?[^>]+hreflang\s*=\s*['"]?de-de['"]?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}