re = /(?i)hreflang\s*=\s*['"]?de-de[^>]+href\s*=\s*['"]?([^'"]*)['"]?|href\s*=\s*['"]?([^"']*)['"]?[^>]+hreflang\s*=\s*['"]?de-de['"]?/
str = '<link rel="alternate" hreflang="de-de" href="https://zrce.eu/" />
<link rel="alternate" hreflang="en-us" href="https://zrce.eu/en/" />
<link rel="alternate" hreflang="it-it" href="https://zrce.eu/it/" />
<link hreflang="de-de" rel="alternate" href="https://zrce.eu/" />
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end