import Foundation
let pattern = #"(?i)hreflang\s*=\s*['"]?de-de[^>]+href\s*=\s*['"]?([^'"]*)['"]?|href\s*=\s*['"]?([^"']*)['"]?[^>]+hreflang\s*=\s*['"]?de-de['"]?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<link rel="alternate" hreflang="de-de" href="https://zrce.eu/" />
<link rel="alternate" hreflang="en-us" href="https://zrce.eu/en/" />
<link rel="alternate" hreflang="it-it" href="https://zrce.eu/it/" />
<link hreflang="de-de" rel="alternate" href="https://zrce.eu/" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)