package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)hreflang\s*=\s*['"]?de-de[^>]+href\s*=\s*['"]?([^'"]*)['"]?|href\s*=\s*['"]?([^"']*)['"]?[^>]+hreflang\s*=\s*['"]?de-de['"]?`)
var str = `<link rel="alternate" hreflang="de-de" href="https://zrce.eu/" />
<link rel="alternate" hreflang="en-us" href="https://zrce.eu/en/" />
<link rel="alternate" hreflang="it-it" href="https://zrce.eu/it/" />
<link hreflang="de-de" rel="alternate" href="https://zrce.eu/" />
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}