// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)hreflang\s*=\s*['"]?de-de[^>]+href\s*=\s*['"]?([^'"]*)['"]?|href\s*=\s*['"]?([^"']*)['"]?[^>]+hreflang\s*=\s*['"]?de-de['"]?"#).unwrap();
let string = "<link rel=\"alternate\" hreflang=\"de-de\" href=\"https://zrce.eu/\" />
<link rel=\"alternate\" hreflang=\"en-us\" href=\"https://zrce.eu/en/\" />
<link rel=\"alternate\" hreflang=\"it-it\" href=\"https://zrce.eu/it/\" />
<link hreflang=\"de-de\" rel=\"alternate\" href=\"https://zrce.eu/\" />
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}