$re = '/(?i)hreflang\s*=\s*[\'"]?de-de[^>]+href\s*=\s*[\'"]?([^\'"]*)[\'"]?|href\s*=\s*[\'"]?([^"\']*)[\'"]?[^>]+hreflang\s*=\s*[\'"]?de-de[\'"]?/';
$str = '<link rel="alternate" hreflang="de-de" href="https://zrce.eu/" />
<link rel="alternate" hreflang="en-us" href="https://zrce.eu/en/" />
<link rel="alternate" hreflang="it-it" href="https://zrce.eu/it/" />
<link hreflang="de-de" rel="alternate" href="https://zrce.eu/" />
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);