import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)hreflang\\s*=\\s*['\"]?de-de[^>]+href\\s*=\\s*['\"]?([^'\"]*)['\"]?|href\\s*=\\s*['\"]?([^\"']*)['\"]?[^>]+hreflang\\s*=\\s*['\"]?de-de['\"]?";
final String string = "<link rel=\"alternate\" hreflang=\"de-de\" href=\"https://zrce.eu/\" />\n"
+ "<link rel=\"alternate\" hreflang=\"en-us\" href=\"https://zrce.eu/en/\" />\n"
+ "<link rel=\"alternate\" hreflang=\"it-it\" href=\"https://zrce.eu/it/\" />\n"
+ "<link hreflang=\"de-de\" rel=\"alternate\" href=\"https://zrce.eu/\" />\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}