#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(ab|cd)\??"
Local $sString = "id" & @CRLF & _
"ab? op" & @CRLF & _
"ab? 1" & @CRLF & _
"cd" & @CRLF & _
"efab? cba" & @CRLF & _
"efab? 1" & @CRLF & _
"efab? 2" & @CRLF & _
"fab? 4" & @CRLF & _
"fab? po"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")