import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(ab|cd)\\??";
final String string = "id\n"
+ "ab? op\n"
+ "ab? 1\n"
+ "cd\n"
+ "efab? cba\n"
+ "efab? 1\n"
+ "efab? 2\n"
+ "fab? 4\n"
+ "fab? po";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}