const regex = new RegExp('\\b(ab|cd)\\??', 'gm')
const str = `id
ab? op
ab? 1
cd
efab? cba
efab? 1
efab? 2
fab? 4
fab? po`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}