import re
regex = re.compile(r"\b(ab|cd)\??", flags=re.MULTILINE)
test_str = ("id\n"
"ab? op\n"
"ab? 1\n"
"cd\n"
"efab? cba\n"
"efab? 1\n"
"efab? 2\n"
"fab? 4\n"
"fab? po")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")