$re = '/\b(ab|cd)\??/m';
$str = 'id
ab? op
ab? 1
cd
efab? cba
efab? 1
efab? 2
fab? 4
fab? po';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);