package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(ab|cd)\??`)
var str = `id
ab? op
ab? 1
cd
efab? cba
efab? 1
efab? 2
fab? 4
fab? po`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}