// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(ab|cd)\??").unwrap();
let string = "id
ab? op
ab? 1
cd
efab? cba
efab? 1
efab? 2
fab? 4
fab? po";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}