using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(ab|cd)\??";
string input = @"id
ab? op
ab? 1
cd
efab? cba
efab? 1
efab? 2
fab? 4
fab? po";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}