re = /\b(ab|cd)\??/m
str = 'id
ab? op
ab? 1
cd
efab? cba
efab? 1
efab? 2
fab? 4
fab? po'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end