# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<[^>]+>//gm;t' <<< "'Some text ' +
'<input type=\"hidden\" id=\"hiddenField\" value=\"3\" /> ' +
'<input type=\"text\" id=\"textField\"/>'"