re = /<[^>]+>/m
str = '\'Some text \' +
\'<input type="hidden" id="hiddenField" value="3" /> \' +
\'<input type="text" id="textField"/>\''
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result