$re = '/<[^>]+>/m';
$str = '\'Some text \' +
\'<input type="hidden" id="hiddenField" value="3" /> \' +
\'<input type="text" id="textField"/>\'';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;