import re
regex = re.compile(r"<[^>]+>", flags=re.MULTILINE)
test_str = ("'Some text ' + \n"
" '<input type=\"hidden\" id=\"hiddenField\" value=\"3\" /> ' +\n"
" '<input type=\"text\" id=\"textField\"/>'")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)