use strict;
my $str = '\'Some text \' +
\'<input type="hidden" id="hiddenField" value="3" /> \' +
\'<input type="text" id="textField"/>\'';
my $regex = qr/<[^>]+>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";