# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^namespace{1}.*\W\n?{)//gm;t' <<< "namespace HP.Core.Extensions.ExtensionMethods
{
public static partial class FileInfoExtension
{
public static System.String GetDirectoryName(this FileInfo @this)
{
return @this.Directory.Name;
}
}
}
"