import re
regex = re.compile(r"(^namespace{1}.*\W\n?{)", flags=re.MULTILINE)
test_str = ("namespace HP.Core.Extensions.ExtensionMethods\n"
"{\n"
" public static partial class FileInfoExtension\n"
" {\n"
" public static System.String GetDirectoryName(this FileInfo @this)\n"
" {\n"
" return @this.Directory.Name;\n"
" }\n"
" }\n"
"}\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)