use strict;
my $str = 'namespace HP.Core.Extensions.ExtensionMethods
{
public static partial class FileInfoExtension
{
public static System.String GetDirectoryName(this FileInfo @this)
{
return @this.Directory.Name;
}
}
}
';
my $regex = qr/(^namespace{1}.*\W\n?{)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";