const regex = /(^namespace{1}.*\W\n?{)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^namespace{1}.*\\W\\n?{)', 'gm')
const str = `namespace HP.Core.Extensions.ExtensionMethods
{
public static partial class FileInfoExtension
{
public static System.String GetDirectoryName(this FileInfo @this)
{
return @this.Directory.Name;
}
}
}
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);