// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^namespace{1}.*\W\n?{)").unwrap();
let string = "namespace HP.Core.Extensions.ExtensionMethods
{
public static partial class FileInfoExtension
{
public static System.String GetDirectoryName(this FileInfo @this)
{
return @this.Directory.Name;
}
}
}
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}