#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?'region'{region "workcellX"}.*?(?'IafId'(?<={attribute 'IafId' := ').*?(?='})).*?{endregion})"
Local $sString = " {region "workcellX"}" & @CRLF & _
" ,workcellX" & @CRLF & _
" {attribute 'IafId' := '1745cf20-b0f5-45c7-903f-ee6679d073a9'}" & @CRLF & _
" {endregion}" & @CRLF & _
" {region "workcellX"" & @CRLF & _
" ,workcellX" & @CRLF & _
" {attribute 'IafId' := '1745cf20-b0f5-45c7-903f-ee6679d073a9'}" & @CRLF & _
" {endregion}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")