const regex = /(?'region'{region "workcellX"}.*?(?'IafId'(?<={attribute 'IafId' := ').*?(?='})).*?{endregion})/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?\'region\'{region "workcellX"}.*?(?\'IafId\'(?<={attribute \'IafId\' := \').*?(?=\'})).*?{endregion})', 'gms')
const str = ` {region "workcellX"}
,workcellX
{attribute 'IafId' := '1745cf20-b0f5-45c7-903f-ee6679d073a9'}
{endregion}
{region "workcellX"
,workcellX
{attribute 'IafId' := '1745cf20-b0f5-45c7-903f-ee6679d073a9'}
{endregion}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}