$re = '/(?\'region\'{region "workcellX"}.*?(?\'IafId\'(?<={attribute \'IafId\' := \').*?(?=\'})).*?{endregion})/ms';
$str = ' {region "workcellX"}
,workcellX
{attribute \'IafId\' := \'1745cf20-b0f5-45c7-903f-ee6679d073a9\'}
{endregion}
{region "workcellX"
,workcellX
{attribute \'IafId\' := \'1745cf20-b0f5-45c7-903f-ee6679d073a9\'}
{endregion}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);