import re
regex = re.compile(r"(?'region'{region \"workcellX\"}.*?(?'IafId'(?<={attribute 'IafId' := ').*?(?='})).*?{endregion})", flags=re.MULTILINE | re.DOTALL)
test_str = (" {region \"workcellX\"}\n"
" ,workcellX\n"
" {attribute 'IafId' := '1745cf20-b0f5-45c7-903f-ee6679d073a9'}\n"
" {endregion}\n"
" {region \"workcellX\"\n"
" ,workcellX\n"
" {attribute 'IafId' := '1745cf20-b0f5-45c7-903f-ee6679d073a9'}\n"
" {endregion}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")