use strict;
my $str = ' {region "workcellX"}
,workcellX
{attribute \'IafId\' := \'1745cf20-b0f5-45c7-903f-ee6679d073a9\'}
{endregion}
{region "workcellX"
,workcellX
{attribute \'IafId\' := \'1745cf20-b0f5-45c7-903f-ee6679d073a9\'}
{endregion}';
my $regex = qr/(?'region'{region "workcellX"}.*?(?'IafId'(?<={attribute 'IafId' := ').*?(?='})).*?{endregion})/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}