using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?'region'{region ""workcellX""}.*?(?'IafId'(?<={attribute 'IafId' := ').*?(?='})).*?{endregion})";
string input = @" {region ""workcellX""}
,workcellX
{attribute 'IafId' := '1745cf20-b0f5-45c7-903f-ee6679d073a9'}
{endregion}
{region ""workcellX""
,workcellX
{attribute 'IafId' := '1745cf20-b0f5-45c7-903f-ee6679d073a9'}
{endregion}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}