# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a(?:\s+\w+\s*=\s*(?P<quote>["']).*?(?P=quote))*)\s+class\s*=\s*(?P<q>["']).*?(?P=q)/\1/g;t' <<< "<p class=\"red\">Link: <a href=\"http://www.google.com\" style =\"margin: 0px\">google</a>.</p>
<p class=\"red\">Link: <a href=\"http://www.google.com\" class = \"link\" style=\"margin: 0px\" >google</a>.</p>
<a class='foo'>link text</a>"