using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a(?:\s+\w+\s*=\s*(?P<quote>[""']).*?(?P=quote))*)\s+class\s*=\s*(?P<q>[""']).*?(?P=q)";
string substitution = @"\1";
string input = @"<p class=""red"">Link: <a href=""http://www.google.com"" style =""margin: 0px"">google</a>.</p>
<p class=""red"">Link: <a href=""http://www.google.com"" class = ""link"" style=""margin: 0px"" >google</a>.</p>
<a class='foo'>link text</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}