import re
regex = re.compile(r"(<a(?:\s+\w+\s*=\s*(?P<quote>[\"']).*?(?P=quote))*)\s+class\s*=\s*(?P<q>[\"']).*?(?P=q)")
test_str = ("<p class=\"red\">Link: <a href=\"http://www.google.com\" style =\"margin: 0px\">google</a>.</p>\n"
"<p class=\"red\">Link: <a href=\"http://www.google.com\" class = \"link\" style=\"margin: 0px\" >google</a>.</p>\n"
"<a class='foo'>link text</a>")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)