import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a(?:\\s+\\w+\\s*=\\s*(?P<quote>[\"']).*?(?P=quote))*)\\s+class\\s*=\\s*(?P<q>[\"']).*?(?P=q)";
final String string = "<p class=\"red\">Link: <a href=\"http://www.google.com\" style =\"margin: 0px\">google</a>.</p>\n"
+ "<p class=\"red\">Link: <a href=\"http://www.google.com\" class = \"link\" style=\"margin: 0px\" >google</a>.</p>\n"
+ "<a class='foo'>link text</a>";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}