#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<a(?:\s+\w+\s*=\s*(?P<quote>["']).*?(?P=quote))*)\s+class\s*=\s*(?P<q>["']).*?(?P=q)"
Local $sString = "<p class="red">Link: <a href="http://www.google.com" style ="margin: 0px">google</a>.</p>" & @CRLF & _
"<p class="red">Link: <a href="http://www.google.com" class = "link" style="margin: 0px" >google</a>.</p>" & @CRLF & _
"<a class='foo'>link text</a>"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)