re = /(<a(?:\s+\w+\s*=\s*(?P<quote>["']).*?(?P=quote))*)\s+class\s*=\s*(?P<q>["']).*?(?P=q)/
str = '<p class="red">Link: <a href="http://www.google.com" style ="margin: 0px">google</a>.</p>
<p class="red">Link: <a href="http://www.google.com" class = "link" style="margin: 0px" >google</a>.</p>
<a class=\'foo\'>link text</a>'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result