use strict;
my $str = '<p class="red">Link: <a href="http://www.google.com" style ="margin: 0px">google</a>.</p>
<p class="red">Link: <a href="http://www.google.com" class = "link" style="margin: 0px" >google</a>.</p>
<a class=\'foo\'>link text</a>';
my $regex = qr/(<a(?:\s+\w+\s*=\s*(?P<quote>["']).*?(?P=quote))*)\s+class\s*=\s*(?P<q>["']).*?(?P=q)/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";