package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<a(?:\s+\w+\s*=\s*(?P<quote>["']).*?(?P=quote))*)\s+class\s*=\s*(?P<q>["']).*?(?P=q)`)
var str = `<p class="red">Link: <a href="http://www.google.com" style ="margin: 0px">google</a>.</p>
<p class="red">Link: <a href="http://www.google.com" class = "link" style="margin: 0px" >google</a>.</p>
<a class='foo'>link text</a>`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}