#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\\\/\\\\\.\\\\]"
Local $sString = "$$\left[ x=\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{{{3}\over{2" & @CRLF & _
" }}}}}\right)^{{{1}\over{3}}}\,\left(-{{1}\over{2}}-{{\sqrt{3}\,i" & @CRLF & _
" }\over{2}}\right)-{{{{\sqrt{3}\,i}\over{2}}-{{1}\over{2}}}\over{3\," & @CRLF & _
" \left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{{{3}\over{2}}}}}" & @CRLF & _
" \right)^{{{1}\over{3}}}}} , x=\left({{11}\over{2}}+{{\sqrt{3271}" & @CRLF & _
" }\over{2\,3^{{{3}\over{2}}}}}\right)^{{{1}\over{3}}}\,\left({{\sqrt{" & @CRLF & _
" 3}\,i}\over{2}}-{{1}\over{2}}\right)-{{-{{1}\over{2}}-{{\sqrt{3}\,i" & @CRLF & _
" }\over{2}}}\over{3\,\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{" & @CRLF & _
" {{3}\over{2}}}}}\right)^{{{1}\over{3}}}}} , x=\left({{11}\over{2}}+" & @CRLF & _
" {{\sqrt{3271}}\over{2\,3^{{{3}\over{2}}}}}\right)^{{{1}\over{3}}}-{{" & @CRLF & _
" 1}\over{3\,\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{{{3}\over{" & @CRLF & _
" 2}}}}}\right)^{{{1}\over{3}}}}} \right] $$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")