const regex = /[\\\/\\\\\.\\\\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\\\\\\/\\\\\\\\\\.\\\\\\\\]', 'g')
const str = `\$\$\\left[ x=\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2
}}}}}\\right)^{{{1}\\over{3}}}\\,\\left(-{{1}\\over{2}}-{{\\sqrt{3}\\,i
}\\over{2}}\\right)-{{{{\\sqrt{3}\\,i}\\over{2}}-{{1}\\over{2}}}\\over{3\\,
\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2}}}}}
\\right)^{{{1}\\over{3}}}}} , x=\\left({{11}\\over{2}}+{{\\sqrt{3271}
}\\over{2\\,3^{{{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}\\,\\left({{\\sqrt{
3}\\,i}\\over{2}}-{{1}\\over{2}}\\right)-{{-{{1}\\over{2}}-{{\\sqrt{3}\\,i
}\\over{2}}}\\over{3\\,\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{
{{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}}} , x=\\left({{11}\\over{2}}+
{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{2}}}}}\\right)^{{{1}\\over{3}}}-{{
1}\\over{3\\,\\left({{11}\\over{2}}+{{\\sqrt{3271}}\\over{2\\,3^{{{3}\\over{
2}}}}}\\right)^{{{1}\\over{3}}}}} \\right] \$\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}