using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\\\/\\\\\.\\\\]";
string input = @"$$\left[ x=\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{{{3}\over{2
}}}}}\right)^{{{1}\over{3}}}\,\left(-{{1}\over{2}}-{{\sqrt{3}\,i
}\over{2}}\right)-{{{{\sqrt{3}\,i}\over{2}}-{{1}\over{2}}}\over{3\,
\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{{{3}\over{2}}}}}
\right)^{{{1}\over{3}}}}} , x=\left({{11}\over{2}}+{{\sqrt{3271}
}\over{2\,3^{{{3}\over{2}}}}}\right)^{{{1}\over{3}}}\,\left({{\sqrt{
3}\,i}\over{2}}-{{1}\over{2}}\right)-{{-{{1}\over{2}}-{{\sqrt{3}\,i
}\over{2}}}\over{3\,\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{
{{3}\over{2}}}}}\right)^{{{1}\over{3}}}}} , x=\left({{11}\over{2}}+
{{\sqrt{3271}}\over{2\,3^{{{3}\over{2}}}}}\right)^{{{1}\over{3}}}-{{
1}\over{3\,\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{{{3}\over{
2}}}}}\right)^{{{1}\over{3}}}}} \right] $$";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}