import Foundation
let pattern = #"[\\\/\\\\\.\\\\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$$\left[ x=\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{{{3}\over{2
}}}}}\right)^{{{1}\over{3}}}\,\left(-{{1}\over{2}}-{{\sqrt{3}\,i
}\over{2}}\right)-{{{{\sqrt{3}\,i}\over{2}}-{{1}\over{2}}}\over{3\,
\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{{{3}\over{2}}}}}
\right)^{{{1}\over{3}}}}} , x=\left({{11}\over{2}}+{{\sqrt{3271}
}\over{2\,3^{{{3}\over{2}}}}}\right)^{{{1}\over{3}}}\,\left({{\sqrt{
3}\,i}\over{2}}-{{1}\over{2}}\right)-{{-{{1}\over{2}}-{{\sqrt{3}\,i
}\over{2}}}\over{3\,\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{
{{3}\over{2}}}}}\right)^{{{1}\over{3}}}}} , x=\left({{11}\over{2}}+
{{\sqrt{3271}}\over{2\,3^{{{3}\over{2}}}}}\right)^{{{1}\over{3}}}-{{
1}\over{3\,\left({{11}\over{2}}+{{\sqrt{3271}}\over{2\,3^{{{3}\over{
2}}}}}\right)^{{{1}\over{3}}}}} \right] $$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)